GMC Acadia Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I have a 2015 Acadia and the XM genre shows 'Willie's Rdhouse' instead of Pop, Rock, etc. It only happens when I first start the car. If I change between stations in the same genre, Willie's Rdhouse remains. But if I switch to a different genre, the display corrects itself until I turn the car off again (even if I go back to the station I was on when I started the car). The station name and song name are right, it's just the genre (and I never listen to Willie's Roadhouse, so I'm not sure why that name gets substituted for the genre). I've taken it to the dealer and opened a case with GMC. The dealer replaced the XM receiver and the entire radio, but the problem persists. They suggest it's a problem with XM, but if that were the case I would think there would be a lot of complaints about this issue. There's nothing else the dealer can replace, so they are stuck. Has anyone else had a similar problem? I'm a bit OCD and it's driving me nuts! TIA
 

·
Super Moderator
Joined
·
19,260 Posts
Why would anyone hold GM responsible for what's broadcast to their radio? :shrug: Time to call XM/Sirius and lodge your complaint. :devil: I've experienced FM stations locked onto a particular song title for days at a time. Couldn't blame that on the car!! :eek:hno:
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
I agree with you in concept, but I don't think the wrong info is being broadcast to the radio. If that were the case every radio should be affected. I've talked to XM and they tried sending a refresh signal, and even cancelled and re-established my service to reset the radio. They weren't familiar with this issue. I've also checked other radios (including in an Acadia) and they were correct.

If I'm in my garage, all of the lines go to 'No XM Signal', except the top line switches from 'No XM Signal' to 'Willie's Rdhouse'. Since there's no signal, I wouldn't expect that line to change. If anything, it seems like a software bug to me. I'm just curious if anyone else has noticed it in their cars.
 

·
Super Moderator
Joined
·
19,260 Posts
The XM/Sirius subscription is unique to your satellite radio receiver. Instead of dealing with XM/Sirius customer service, ask if you could talk to someone in their engineering department. The only other possibility related to your car would be the antenna.
 

·
Registered
Joined
·
38 Posts
I've been noticing the "freeze" on my XM stations too, I think it is the XM signal. I just had a similar problem this weekend, 60's on 6 was showing a song that played 3 songs earlier, when I checked 5 and 7 they too were showing the name of a different song then what was playing. When I stopped for fuel and restarted the car the correct song was displayed. Definitely a XM Signal problem.
 

·
Registered
Joined
·
387 Posts
I have the same issue occasionally on my '17 Limited, I really haven't paid much attention to it and it eventually clears itself up. Not enough of a nuisance to bring it in, I'm pretty sure, like others have said it's an XM issue. They're not exactly a Fortune 500 company...
 

·
Registered
Joined
·
11 Posts
Discussion Starter #9
Thanks, everyone. The dealer checked for updates and my software is current. I ordered a new antenna to see if that'll help.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
I replaced the antenna base and mast, but that didn't fix the problem. I'm inclined to think it's a software bug since every part related to XM radio has been replaced. On the bright side, my signal doesn't seem to cut out as much with the new antenna.

PS - I don't recommend replacing the antenna base unless you have a bad signal problem. It's a pain to drop the headliner enough to access the mounting nut and wire connections.
 

·
Super Moderator
Joined
·
19,260 Posts
Since you changed the antenna (and everything else under the satellite :) ), try another 'refresh' and see what happens. Also, go into the display menu options and turn the RDS display function off and on several times, then switch it back on. If you have the option to display playlists (Willie's Roadhouse is a playlist - not a genre), turn that off.
 

·
Registered
Joined
·
160 Posts
I have a 2015 Acadia and the XM genre shows 'Willie's Rdhouse' instead of Pop, Rock, etc. It only happens when I first start the car. If I change between stations in the same genre, Willie's Rdhouse remains. But if I switch to a different genre, the display corrects itself until I turn the car off again (even if I go back to the station I was on when I started the car). The station name and song name are right, it's just the genre (and I never listen to Willie's Roadhouse, so I'm not sure why that name gets substituted for the genre). I've taken it to the dealer and opened a case with GMC. The dealer replaced the XM receiver and the entire radio, but the problem persists. They suggest it's a problem with XM, but if that were the case I would think there would be a lot of complaints about this issue. There's nothing else the dealer can replace, so they are stuck. Has anyone else had a similar problem? I'm a bit OCD and it's driving me nuts! TIA
I've been noticing the "freeze" on my XM stations too, I think it is the XM signal. I just had a similar problem this weekend, 60's on 6 was showing a song that played 3 songs earlier, when I checked 5 and 7 they too were showing the name of a different song then what was playing. When I stopped for fuel and restarted the car the correct song was displayed. Definitely a XM Signal problem.
I know I'm resurrecting a very old thread, but did these clear up for either of you? Seems like every time we start the car we see "Willie's Roadhouse" instead of Rock, Pop, etc. It changes to the correct information as we scroll through the channels, but always starts with Willie. We only see the freeze on long road trips (all channels' display stuck on the song that was playing on that channel when it froze), and that clears up when we stop and turn off the car. We had it in, but dealer couldn't do anything since they couldn't recreate it.
 

·
Registered
Joined
·
805 Posts
I know I'm resurrecting a very old thread, but did these clear up for either of you? Seems like every time we start the car we see "Willie's Roadhouse" instead of Rock, Pop, etc. It changes to the correct information as we scroll through the channels, but always starts with Willie. We only see the freeze on long road trips (all channels' display stuck on the song that was playing on that channel when it froze), and that clears up when we stop and turn off the car. We had it in, but dealer couldn't do anything since they couldn't recreate it.
You could try another dealer? Some are better than others with the electronics in a vehicle than others.
Also, this is a 2 year old post. Might not get much of a response.
 
1 - 13 of 13 Posts
Top