GMC Acadia Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter · #1 ·
Just thought i'd see if anyone else has had a problem with the trip or odometer being sloooooow after the tranny flash. I didn't really notice it until i filled up this morning after having the trans flashed on Monday. It showed 224 miles on it and took 16 gals. That's the worst i've ever seen. I reset the trips and we drove approx. 30 miles today and my trip indicators showed 13.7 miles. That's great for the warranty but that's about it.
 

·
Registered
Joined
·
83 Posts
This problem happens because your dealer's service department didn't reflash both the ECM (engine control module) and the TCM (transmission control module), according to other posts on this topic that I've seen on this forum. The DIC goes wacky when only one module is reflashed.
 

·
Registered
Joined
·
12 Posts
mktuttle said:
This problem happens because your dealer's service department didn't reflash both the ECM (engine control module) and the TCM (transmission control module), according to other posts on this topic that I've seen on this forum. The DIC goes wacky when only one module is reflashed.
yep, had it happen with mine. Only difference is that they jacked it up and the update didn't seem to take. They tried it again and it appears it didn't take. Either their incompetent or the update isn't very good. I'm hoping their just incompetent.
 

·
Registered
Joined
·
524 Posts
Mine was messed up at first. I took it back and the mechanic said that when they flash the tranny that both ecm and tcm flash at the same time. I told him I thought that was incorrect. he sort of looked at me like I was nuts. He went and re flashed it a second time and at first the MPG read 8.0 mpg so I went back in and told him it was still messed up. The mechanic told me that the tranny needed to relearn my shifts and whatnot before it would read correctly. After about 20 miles of driving home my dic read 19 mpg average. I'm doing a couple hundred miles tomorrow so I will see if it goes back to the 24 mpg I was getting on the highway.
 

·
Registered
Joined
·
104 Posts
Discussion Starter · #5 ·
Well, got mine reflashed this morning and all is well with the DIC now. At least i got a free oil change out of having to go back. Service manager told me the guy just missed the wording about flashing both modules.
 

·
Registered
Joined
·
524 Posts
Alls well now. I got my highway mileage up to 24.4 on the highway. Love the new trans!!!
 

·
Registered
Joined
·
3 Posts
I was having the problem as well.

Did you do anything about the odometer discrepancy? Mine is several thousand over. I've been pushing for some type of resolution. Sounds like they may finally have a way to correct the discrepancy.
 
1 - 7 of 7 Posts
Top