GMC Acadia Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Our Acadia has 7000 miles and we have had several small issues to complain about, but we have kept them quiet because we love the vehicle. We took the Acadia in 18 DAYS AGO, because we were having transmission problems where reverse wouldn't engage (unless we shut it off and pulled forward a little) and we also began to experience random shifting at different speeds. We still do not have the Acadia back and to make matters they gave us a Pontiac Grand Prix as a rental. The Grand Prix is NOT a car fit for a family, not sure how they thought the Grand Prix was an equal car.

Can anyone tell us if they are aware of major transmission problems with the Acadia or what we should do. We are at the point of not wanting to ever buy a GMC again, especially since we have had to constantly call for updates on the vehicle and all we get is "we are waiting for parts." We were originally promised it would be fixed in less than a week.
 

·
Registered
Joined
·
207 Posts
rmack72,

From what I've read on this site, the Acadia had a software problem with the transmission where it would hesitate to shift or shift into too high of a gear too early. To fix this, owners had to get their transmission software updated. This might be the problem with your car - you may want to check with the dealer if they updated the transmission software. If they did, perhaps they messed up the software upgrade and need to redo it. From what I understand this problem has been fixed with the software update.

However, the not shifting into reverse may be a solenoid or something, as this is an electronic transmission. You may want to do a search on this site.
 

·
Registered
Joined
·
1 Posts
I too am having a transmission problem of a similar kind. My 2007 Acadia with about 22,000 miles recently started not engaging in reverse. I found it to be most prevelant when the car had been driven for some time , was shut off and was either parked on an incline or decline. I would start the vehicle, place it in reverse and accelerate..either the car would not move or would rev and then slam into gear. A corresponding issue was hard shifting into different gears and an occassional reving on the highway when cruising. Recently,the same problem of not engaging has shown up even when parked on a flat surface. The dealer said that the computer shows no signs of anything wrong...big surprise there. If anyone else is having this problem, can you please let me know what the fix was.
 

·
Premium Member
Joined
·
3,374 Posts
Welcome to the forum. As we usually ask, it is helpful to list your vehicle's specifications in your signature (see Blues Clues on how to do this). Do you know if the transmission has ever been reprogrammed (also known as a flash)? If you do some more research (search for transmission flash) here, you may find relevant info. The member that started this thread was here for 7 days in 2007 and never came back, so I doubt you will hear from them.
 

·
Super Moderator
Joined
·
21,753 Posts
ACADude said:
... a transmission problem ... place it in reverse and accelerate..either the car would not move or would rev and then slam into gear. ... the computer shows no signs of anything wrong...
Is this another case of mechanical failure that is not detected by any sensor? I wish some of these mechanics would get their head out of their USB port and look somewhere else besides the display screen! :banghead: :help: :blob:
 

·
Premium Member
Joined
·
14,870 Posts
speleos said:
I wish some of these mechanics would get their head out of their USB port
:rofl:

Funny but unfortunately true
 
1 - 6 of 6 Posts
Top