GMC Acadia Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
Traction Control Off Service Stabilitrak Engine Power Reduced caused by...

Traction Control Off, Service Stabilitrak, Engine Power Reduced caused by SHORT WIRE HARNESS?!?!?!?!?! How do I figure, well I had this problem back in 2013 when I was jumping into the fast lane on the HWY. I gas the truck a good amount of gas and off the truck goes all for about 1 second then MAYDAY!!! Traction Control Off, Service Stabilitrak, Engine Power Reduced. I took the Acadia to the dealer and they said it throttle bodies and some other crap had to be changed out... 2 years later (had never gas it that way since) I put the peddle to the floor and we took off for about 1-2 seconds from 30mph to about 40mph and then cut out. I let the car sit for a day out of frustration and the following day opened the hood and started poking around. I was EXTREMELY surprised at my finding, I had discovered the wire connection at the throttle body had come completely off!!!!!

I plugged it back in and what do you know it started right up perfectly fine. So I went out for a test run and she ran fine, I put the peddle to the floor and BAM same crap happened. I opened the hood and the connection had come off the throttle body. I concluded the wiring was too short and the flex of the motor in the chassi would cause the connection to pop off. I took it into the dealer with the connection off and they told me the throttle bodies and some other crap had to be replaced again. I laughed and told them why they had not opened the hood. crickets. Anyways just thought I would give your guys a heads up if the issue happens to you, check the connection on the back of the throttle bodies if this happens to you.
 

·
Super Moderator
Joined
·
23,741 Posts

·
Registered
Joined
·
8,802 Posts
Re: Traction Control Off Service Stabilitrak Engine Power Reduced caused by...

is it possible your front engine mount is bad-- allowing the engine to move more than normal to also make that plug come off? (which may also be missing the clip?)
 

·
Registered
Joined
·
32 Posts
Re: Traction Control Off Service Stabilitrak Engine Power Reduced caused by...

Does it look like the latches are broken? Or, did the folks who worked on the throttle body forget to put the 'keeper' back on the connector?

The keeper which secures the harness to the throttle body should look similar to the one in the beginning of this video:

I know this is an old thread — but this just happened to us —any idea where we can find what that ‘keeper’ is called so we can replace it?
 

·
Super Moderator
Joined
·
23,741 Posts
I know this is an old thread — but this just happened to us —any idea where we can find what that ‘keeper’ is called so we can replace it?
You'll have to investigate who supplies that connector, see if they list the piece separately, and find out what they call it. It's likely not something anyone could find on a GM parts list. Salvage yard may be a good choice for locating one.
 

·
Super Moderator
Joined
·
23,741 Posts
A lot of people call them "Gee" clips as in, "Aw, gee! I lost the darned clip!!" (or some other version of that 🤣 )
 

·
Registered
Joined
·
12 Posts
Traction Control Off Service Stabilitrak Engine Power Reduced has been occurring for my 2012 GMC Acadia SLE has been doing this for a while, at random. has anyone else experienced this and found the the throttle body connection to be the cause?
 

·
Registered
Joined
·
4,095 Posts
Traction Control Off Service Stabilitrak Engine Power Reduced has been occurring for my 2012 GMC Acadia SLE has been doing this for a while, at random. has anyone else experienced this and found the the throttle body connection to be the cause?
Are you also getting a check engine light? Sound like step one is to have the vehicle scanned for trouble codes.
 

·
Registered
Joined
·
12 Posts
I've been traveling up north for the summer and so my OBD reader is at home in FL. I went to LUKOIL here in NJ to fill up and then asked the mechanic if he could pull the codes for me. He asked if I had jumped it recently and then cleared the codes. Said to come back if the Check Engine light came back on. SO, he didn't give me the codes... and I told him why I suspected he saw that. Without disconnecting the negative on the batter first I had reseated the wiring harness on the Fuse Panel/box underneath the glovebox on the passenger side. I wanted to see if any water damage , rust or corrosion. So... when they come back I'll get the codes.
 

·
Registered
Joined
·
12 Posts
Update, on my travel home I had two days of driving - no issues. Then one hot day it started and I tried shutting off, waiting a minute, putting key in the ignition, starting... Engine light went on and same issue. Slow easy drive back to the hotel that that night because there was a lose of power for sure. next day, ran like a champ again... next two days same. Back home for a couple days, did it again yesterday on the way home from the store. I got the OBD-II reader out and saw two 2 entries for the following. Not quite sure where to start... I do have a can of contact cleaner, thought I could just start pulling plugs, spraying(cleaning), add some dielectric grease, not really sure but maybe it's something...

1 Code $7E8:Engine
P0697 - Sensor Reference Voltage C Circuit / Open

Research:
The error code P0697 is related to computer output circuit issues and would start appearing if there is an internal computer failure. Now here in this case, it is the engine control module which has detected some defect in the sensor reference voltage “C” circuit.

What causes this problem with the Sensor Reference Voltage “C” Circuit/Open?
  • There can be defective, open, or shorted wiring and connectors between control modules
  • Open or shorted wiring and connectors between engine sensors
  • Some faults in the engine control module
 

·
Registered
Joined
·
12 Posts
update on the issue. Took it to the shop, brake pedal sensor replaced. It appeared to fix it on the trip home but second time driving the errors came back. Reduced Engine power, stabilitrak off errors, and I noticed it took a long time to shift gears. Anyway, it's going back in today.
 

·
Registered
Joined
·
12 Posts
it's 9/1 still not fixed. Shop has put in a new ECM but can't get it programmed. Said they can't get the alarm set correctly. I took my other set of keys to them yesterday. Also, they outsource their computer work to someone and he spent 3 hours today trying to get it to work. Since had the Accelerator Position Sensor and Throttle Body position sensor, somewhat left the ECM aside from wiring and they said getting 5v on all the wires so... Now I'm researching issues with getting the GM security/alarm system setup after ECM replacement.
 
1 - 13 of 13 Posts
Top