GMC Acadia Forum banner

141 - 160 of 183 Posts

·
Premium Member
Joined
·
15,751 Posts
There are times when I wish my 07 had that functionality; but alas; this would require an updated VCIM to operate.

I think a lot of this has to do with antenna location since I seem to recall the antenna runs down the drivers side of the vehicle
 

·
Registered
Joined
·
4,678 Posts
MA Acadia said:
The factory extended remote range on my 2010 sucks, I also brought it to the dealer and they said it was normal. One of the reasons I keep Onstar is because I can start my car from far away with my phone. My old 2003 Malibu with factory remote start has a range of 4X the Acadia range, GM didn't do something right with the remote in the Acadia. :shrug:
I wonder if the antenna for the remote is flexible and isn't in the same position in every Acadia, fallen down behind thicker metal?

What about the battery in the remote, I switch my remotes back and forth every couple of weeks so that they wear evenly (keys included)
 

·
Registered
Joined
·
212 Posts
got my acadia and drove it

1. stabilitrak - parts already arrived and scheduled to have it repaired next week
2. wiper blade- driver side- still big portion cant be cleaned after replacing the blade - i doubt they replaced it or the arm is the actual problem for less than 2yr acadia with less than 25,000 km
3. rear door- still require lots of force to close it compared to other door
4. remote control enhanced or extended range i guess the regular range is just outside the door and the extended is 20ft?

regarding the transmission - when im backing up - rear drive- dont know what term to use. :)
- then i put the gear to drive --- the acadia will like drag -stutter - like theres no power
 

·
Registered
Joined
·
82 Posts
In regards to the reverse to drive question, you may want to do an idle relearn:

On a warm engine, disconnect the battery for a minute. Start the car and let the idle stabilize in park. Then shift to reverse and let the idle stabilize. Then turn on the AC MAX, making sure the temp setting is low enough to kick in the compressor, when still in reverse and let the idle stabilize. Also, turn the high beams on to further load the alt. Then shift to park with the AC still on and let the idle stabilize.

No guarantee, but you may have a poor idle map in your air/fuel matrix in the ECU.
 

·
Registered
Joined
·
212 Posts
im back from the dealer and the part that they repalced is
A install sensor 22739728
cause left rear wss open
h2414 replace l/r wss
1 22739728


GM Part:
SENSOR
Part NO.: 22739728
 

·
Registered
Joined
·
5 Posts
AA/78U-Supreme Forum Moderator said:
Someone research this TSB; GeoHawk, rbarrios could you post the wording from this TSB?
Just got the Acadia back this morning, drove it 6 miles and the CEL illuminated and the "traction control off" "service stabilitrak" "service traction control" warnings were back on. So u-turn and back to the shop, once again the dreaded P0174 "lean bank 2" error. I bet they tell me the preheater on the O2 is bad for that bank...but we shall see.

They did cover the TSB since I was only 28 days out of warranty - TSB PI074C - Parts include: both right and left valve covers, new insulated PCV tube (12616913) and gaskets. Beware if you do this yourself, it is noted on my invoice they broke the nipple off of the power steering reservoir and had to replace it. I think this will cure the problem with the oil build up in the intake hose between the MAF and the throttle body even if it didn't fix my underlying issue.
 

·
Registered
Joined
·
1 Posts
My '08 Acadia is having the same issue with the service Stabilitrak and Traction Control messages flashing on various times without consistency. I believe it with a service break system message and continues after having replaced brake cylinder and brake boosters...about $600 worth of repairs with under 50,000 miles. Dealer said the computer may need to be reset after the brake work was done but the messages still come on. I see the other posts on possible solutions, but I'm tired of the guessing game and the repair after repair. First GMC and NOT impressed. First week purchased the ECM went out but under warranty so replaced. Sunroof leaks through the airbag deployment area, car will not start after fueling whether I too off or not, and if it rains my power steering may not work bc I've been told water gets on the belt and causes it to slip. The solution was a deflector but I already have a deflector so nothing was done to fix the problem.
 

·
Registered
Joined
·
733 Posts
Nvr2loud said:
I wonder if the antenna for the remote is flexible and isn't in the same position in every Acadia, fallen down behind thicker metal?

What about the battery in the remote, I switch my remotes back and forth every couple of weeks so that they wear evenly (keys included)
Not sure about a antenna but you would hope the dealer looked at that when I brought it in. I think most people complain about the range of the remote start in the 2010 plus Acadia. I did try a new battery in the remote and that did not help at all, I even tried the other remote and same thing. :thumbdown:

MOD EDIT; CORRECTED QUOTE/POST COMBINATION[/color]
 

·
Registered
Joined
·
2,641 Posts
LemonKat said:
My '08 Acadia is having the same issue with the service Stabilitrak and Traction Control messages flashing on various times without consistency. I believe it with a service break system message and continues after having replaced brake cylinder and brake boosters...about $600 worth of repairs with under 50,000 miles. Dealer said the computer may need to be reset after the brake work was done but the messages still come on. I see the other posts on possible solutions, but I'm tired of the guessing game and the repair after repair. First GMC and NOT impressed. First week purchased the ECM went out but under warranty so replaced. Sunroof leaks through the airbag deployment area, car will not start after fueling whether I too off or not, and if it rains my power steering may not work bc I've been told water gets on the belt and causes it to slip. The solution was a deflector but I already have a deflector so nothing was done to fix the problem.
Hey LemonKat,

Sorry to read about all the issues you have been having! If you would like me to try and help out just let me know! To get the ball rolling private message me your VIN, name, address and the name of the dealer you have been working with. Also if you could give me some more details about what happened with your Acadia. Have you reached out to customer service in the past about this?

I hope you have a great day!

Kelly J.
GMC Customer Care

MOD EDIT; DELETED MULTIPLE QUOTES OF THE SAME THREAD RESPONSE[/color]
 

·
Registered
Joined
·
5 Posts
When I finally got my Acadia back, they had solved the problem, there was a reported 665 mis-fires on Cyl #1, checked the coil, but it was good, did a leak down on the injectors and found #1 injector bad, replaced it and viola! everything is good once again. They rolled the cost of that injector into the warranty repair ;D

End of story :cheers:

corporateoffroader said:
Just got the Acadia back this morning, drove it 6 miles and the CEL illuminated and the "traction control off" "service stabilitrak" "service traction control" warnings were back on. So u-turn and back to the shop, once again the dreaded P0174 "lean bank 2" error. I bet they tell me the preheater on the O2 is bad for that bank...but we shall see.

They did cover the TSB since I was only 28 days out of warranty - TSB PI074C - Parts include: both right and left valve covers, new insulated PCV tube (12616913) and gaskets. Beware if you do this yourself, it is noted on my invoice they broke the nipple off of the power steering reservoir and had to replace it. I think this will cure the problem with the oil build up in the intake hose between the MAF and the throttle body even if it didn't fix my underlying issue.
 

·
Registered
Joined
·
1 Posts
I'm having same problem with my Acadia 2008 92k miles. I have been working to solve the issue myself. I just put new brakes on the front and cleaning ABS sensors, I also cleaned the back ABS sensors. They were very dirty... I use my air hose to clean behind the rotors also. About to go pick up kids from school. I will post update when I reture to see if that fixed my problem with brake and stabilitrak.
 

·
Registered
Joined
·
2 Posts
I have an 08 Acadia AWD. I had the "Traction Control Off, Service Stabilitrac and Service Traction Control" message along with the check engine light and the Traction Control light on my dash. When the lights came on there was a noticable pause in my power (like a transmission slip)and then my tac would jump with the 'slip' again everytime the car shifted. Even on slowdown you could feel every gear change similar to downshifting a manual transmission. It reset's when I turn off the ingnition. It's only been 6 months since I had to have it towed to the dealer because the transmission failed and I was stranded. After 3 trips and 3 weeks without my car, their solution seemed to have worked until now. I don't know if they are related but when I took it in for this Stabilitrak issue, the first thing they told me was my warranty was up. I (luckily) purchase an extended warranty so we're good.
This is what my service invoice said:
Scanned code P0101, P0106 tested both passing this code, happens with air filter change with key on ? Road tested can not feel any problem, fluid full & clean. Cannot replicate problem.
Bottom line, nothing. Of course it happened again on my drive home so I signed up for OnStar and got diagnostic, again, thier report was that everything was ok.
So if everything is ok, WHY does my Traction Control go off and shifting slip? I don't think it's a good idea to just keep driving it in this condition, it's just not safe. Any advice would be helpful.
 

·
Registered
Joined
·
2 Posts
I continue to get the CEL & Traction Control Off on a daily basis, now the Check Engine light stays on. Onstar was able to get the following codes yesterday: C0561 - should service in 5 days and P0101 - should service in 1 day if light does not clear after 7 times turning off and on (really?) I have an appt with dealer again for tomorrow, will keep you updated.
So far, with all the research I have seen in this and other forums, here are the causes per the Dealers and GM:
Check/replace timing chain
Check==Coil Packs-Cam Shaft Sensor-Air Mass Flow Sensor-Manifold Absolute Pressure Sensor-Throttle Body leak/clean-Purge Solenoid-Shifter Cable (pin placement)-Cam Shaft Actuator-Cam Position Sensor-Steering Wheel position Sensor-Valve Covers, Master Cylinder,,,,,,need I say more?

I have 93K miles now. Not sure how much of the above would be covered under my extended warranty (through Chrysler) but I'm a little scared.
 

·
Registered
Joined
·
2,641 Posts
KDunc said:
I continue to get the CEL & Traction Control Off on a daily basis, now the Check Engine light stays on. Onstar was able to get the following codes yesterday: C0561 - should service in 5 days and P0101 - should service in 1 day if light does not clear after 7 times turning off and on (really?) I have an appt with dealer again for tomorrow, will keep you updated.
So far, with all the research I have seen in this and other forums, here are the causes per the Dealers and GM:
Check/replace timing chain
Check==Coil Packs-Cam Shaft Sensor-Air Mass Flow Sensor-Manifold Absolute Pressure Sensor-Throttle Body leak/clean-Purge Solenoid-Shifter Cable (pin placement)-Cam Shaft Actuator-Cam Position Sensor-Steering Wheel position Sensor-Valve Covers, Master Cylinder,,,,,,need I say more?

I have 93K miles now. Not sure how much of the above would be covered under my extended warranty (through Chrysler) but I'm a little scared.
Hey KDunc,
If you would like Jessica or I to run your VIN before you go to the dealer tomorrow, let us know! We can check on anything else you might need to be aware of. Private message us your vehicle identification number and reference this thread. Thanks, Kelly J. -GMC Customer Care
 

·
Registered
Joined
·
1 Posts
June 9, 2013 ~My 2007 Acadia with 116,000 miles went on the blink last night. The car was in drive and the dash readout read 'stabilitrack off' and engine light can on, then the a/c pumped out warm air (here in hot FL) and the dash readout was flashing all different announcements with the engine running hot. After we turned off engine the alarm was going off due to overheated engine, which was draining the battery after about 5 hours. Had car towed to local GMC dealer and will wait for diagnosis. Husband fed up with chronic repairs over the years and doesn't want to dump any more $ into it. Does anyone have any input? I love the car but not enough to keep it any longer especially since it's off warranty! What kind of repairs would be necessary and any idea of cost? Thanks.
 

·
Registered
Joined
·
1 Posts
My wife and I bought a 2008 Acadia used from GMC 3 month ago. When we first did the financing they offered us a warranty on it. But when the bank came back and said that they had to lower the price, there went the warranty. The truck had 82k miles on it when we bought it. The first month it was fine. Then we had a "Service Battery Charging System" light and message followed by "Traction Control Off/Service Stabilitrak" messages. When I called GMC customer service, they said that they could not do anything about it because it was not a "Certified" Used Car. So I called the dealership where I bought the vehicle. They told us that it was the battery and it needed to be replaced. So, yesterday I went and bought a battery and replaced it. The light stayed off for a few hours and then on my way to work this morning then lights returned. Any ideas?
 

·
Registered
Joined
·
339 Posts
Battery would have been my first guess too. However, since the lights returned the next step is to get the alternator checked as it may not be working properly.
Worry about the traction control warning after you fix the electrical problem as the TC light many times comes on when there are other problems with the vehicle and goes away when everything else is fixed..
 

·
Registered
Joined
·
2,641 Posts
robert_jones06 said:
My wife and I bought a 2008 Acadia used from GMC 3 month ago. When we first did the financing they offered us a warranty on it. But when the bank came back and said that they had to lower the price, there went the warranty. The truck had 82k miles on it when we bought it. The first month it was fine. Then we had a "Service Battery Charging System" light and message followed by "Traction Control Off/Service Stabilitrak" messages. When I called GMC customer service, they said that they could not do anything about it because it was not a "Certified" Used Car. So I called the dealership where I bought the vehicle. They told us that it was the battery and it needed to be replaced. So, yesterday I went and bought a battery and replaced it. The light stayed off for a few hours and then on my way to work this morning then lights returned. Any ideas?
Hello! I am interested in learning more about the issue that occurred regarding your GM certified dealership. Please private message me the details.

Safe travels,

Jennifer T.
GM Customer Care
 
141 - 160 of 183 Posts
About this Discussion
182 Replies
83 Participants
speleos
GMC Acadia Forum
Join our Acadia Forum community where enthusiasts discuss mods and troubleshooting for the GMC Acadia and Denali Crossover SUV.
Full Forum Listing
Top