GMC Acadia Forum banner

1 - 20 of 157 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Has anyone else had issues with their Blind spot detection system. Every time I start my vehicle I get a warning on my display that says "Service side detection system". The indicators in my mirrors will not come on when a vehicle is on my side or the passenger one will always be on. I've had the vehicle in 4 time and had a module replaced twice. It works for 2 weeks then I get the warning again. Crappy dealership near me does not seem to be able to fix it or care. Starting to think I have a lemon.
 

·
Registered
Joined
·
4,678 Posts
delaneyblue said:
Has anyone else had issues with their Blind spot detection system. Every time I start my vehicle I get a warning on my display that says "Service side detection system". The indicators in my mirrors will not come on when a vehicle is on my side or the passenger one will always be on. I've had the vehicle in 4 time and had a module replaced twice. It works for 2 weeks then I get the warning again. Crappy dealership near me does not seem to be able to fix it or care. Starting to think I have a lemon.
You likely don't have a lemon, but you do have an issue. Take it to another dealership and explain what has been replaced already. Sounds like there might be a bad sensor or wire pinched somewhere. The module is likely the easiest part to replace, so the dealership just tries that first instead of troubleshooting properly.
 

·
Registered
Joined
·
8,458 Posts
will this help?

No Communication with the Right Side Object Detection/Blind Zone Sensor Module
May 6, 2013

Some 2013 Enclave, Traverse and Acadia models equipped with Side Obstacle Detection (RPO UFT) may show no data on the Tech 2 or it’s not possible to program the Right Side Object Detection/Blind Zone sensor module. DTC B101E Sym42 (Electronic Control Unit Software Calibration Not Programmed) may be set.

At this time, there is a Tech 2 software issue preventing communication or programming with the right Side Object Detection sensor module. Programming for both the left and right modules is the same.

Until the software issue is resolved, program both modules in the left position and then install one of them in the right position.

Diagnostic information for DTC B1010E and ID Info can be obtained using a 2013 Cadillac Escalade with navigation on the Tech 2. The module has no Data Display or Device Control support.

The Side Object Detection sensor modules (Fig. 8) can be swapped from left to right to aid in isolating the cause of a condition.
 

·
Registered
Joined
·
137 Posts
did y'all ever wonder how we can find out info like this online and the dealer remains clueless?? :confused:

An owner should not have to tell a tech how to isolate a problem and try a possible fix after a failed attempt, or two, or three, or.............
 

·
Registered
Joined
·
4,678 Posts
BLUE OVAL said:
did y'all ever wonder how we can find out info like this online and the dealer remains clueless?? :confused:

An owner should not have to tell a tech how to isolate a problem and try a possible fix after a failed attempt, or two, or three, or.............
It is the way we pay the techs that causes many issues....

Techs are paid book hours, not actual hours typically. That means that if book hours on a given job is 4.5 hours and the tech takes 6 hours to do the job, he loses money. On the other hand, if the tech only takes 1.5 hours, he moves on to another vehicle and actually makes more money per hour since both jobs technically happen at the same time. There is no motivation to troubleshoot. If you are forced to come back, the tech gets more hours again.

This can be solved by paying techs per hour worked, not book hours. It could also help to have the tech communicate directly with the customer, as there is a sense of pride or a sense of shame / failure for the job done (or not done well) Having service writers is stupid.
 

·
Registered
Joined
·
2,641 Posts
delaneyblue said:
Has anyone else had issues with their Blind spot detection system. Every time I start my vehicle I get a warning on my display that says "Service side detection system". The indicators in my mirrors will not come on when a vehicle is on my side or the passenger one will always be on. I've had the vehicle in 4 time and had a module replaced twice. It works for 2 weeks then I get the warning again. Crappy dealership near me does not seem to be able to fix it or care. Starting to think I have a lemon.
Hello delaneyblue,

I truly understand the frustration of not having your service side detection system work properly after repairs.

As your fellow member suggested, we can help you get in touch with a new dealership so they can diagnose your concern and look into this further. Or we can contact the dealership that performed the repairs as well.

We’d be happy to assist you in this. You can send us a private message with your VIN, current mileage, your full name and contact information, as well as the name of your preferred dealer or zip code if you’d like us to find you a new dealership.

Regards,

Claudia
GMC Customer Care
 

·
Registered
Joined
·
7 Posts
2013, black Acadia Denali...55,000k...first GMC car
I initially started having problems with the message "service side detction system". Brought it in to be serviced and was told that it was a $600 dollar module that needed to be replaced out of warranty. I also was having intermittent blinker problems (exterior blinker would work but the interior dash indicators would blink 3 times and pause for a long time and repeat...this occured on both sides). At the time that I brought the car in, the blinker issue wasn't happening and they said there were "no error messages". While waiting for the part to come in additional electrical issues have come up. The rear side cross alerts don't work. The whole dash went blinked on and off black, the XM radio doesn't work (called XM and the subscription is still good and they resent the signal to no avail), I get intermittent brief blinking of the dash with "service air bag" warnings. The front windshield projection system blinks off and then reboots with the GMC logo. The nav system was off by several blocks when I was driving in Boston the last two times. I have loved the car up until this point but it seems to point to a serious electrical issue. It is currently in the shop being looked at. I would be VERY hesitant to buy another GMC with this kind of problem in a car that is barely 2 years old. The dealer did pro-rate the module given how young the car is even though it is "out of warranty" but this seems to be just the tip of the iceberg. Anyone have any ideas of what is going on here????
 

·
Registered
Joined
·
7 Posts
Re: "Service side detection system"/faulty electrical system

The plot sickens....the dealer has no idea what is going on with the electrical system. They seem to think that the bad side module has nothing to do with the what is going on with the rest of the electrical issues which I find unlikely given that they all started having problems at the same time. I had authorized the dealer $95 to diagnose the problem and they called and said we couldn't figure out what was going on in the first hour and we need another $95 to continue!! This is all at the same time they are already repairing the side blind spot detection module. Not happy and very frustrated!!!! We've owned Fords, Hondas, Toyotas, Dodges and other vehicles and never have we had issues like this.
 

·
Registered
Joined
·
21 Posts
I have some of the same problems that started over 2 months ago. Mine is a 2013 Denali with only 27,000 miles on it. Took it to the dealer and they said they needed a part, which part I do not not know. Said they had to order it, OK, waited a month and went back, part still backordered. Now its been another month, nothing. Mine started with the side detection system light on. Then the turn signal started about a month later, acted up like yours. I am going to go back to the dealer to find out what the hell is going on. Luckily mine is still under warrantee.

Don't we have a GMC person that monitors this website? We need he/she to find out if GMC is having a problem with this. And why are the parts not available.
 

·
Super Moderator
Joined
·
18,323 Posts
turfit2 said:
...
Don't we have a GMC person that monitors this website? We need he/she to find out if GMC is having a problem with this. And why are the parts not available.
Yes, and they're here to help on an individual basis. Send them a private message (PM) with your vehicle info, name of the dealer where the work is being performed, and a description of your concern. That's the only way you can get an answer from them. They don't contribute solutions directly to the forum.
 

·
Registered
Joined
·
7 Posts
After a full day at the dealer, they have no idea what is going on except to charge me diagnostic hours and to confirm that the xm radio doesn't work. I refused to pick up my car until I talk to the service manager. Mine is out of warranty so this is not looking good financially or that they know what is going on. I will try to contact GMC the way Speleos suggested.
 

·
Registered
Joined
·
7 Posts
Update: The dealership has worked with us in terms of repair costs for which we are very grateful. Apparently the side detection module and the radio receiver module are both bad and the radio one will get installed tomorrow. They still don't have any reason why all the other stuff is going on or what caused the modules to fail. Although they said the side detection module is located on the outside so that can be more susceptible to moisture, etc. I'm just concerned that these modules dying are a symptom of a greater electrical problem and that we will just be waiting for the next module to short out especially given all the other electrical wackiness that was happening. I guess time will tell...
 

·
Registered
Joined
·
5 Posts
Well, chalk up another side detection module...... Our (new to us) 2013 Denali with 27,000 on the clock had this error message on the DIC when we first took it for a test drive. Sales manager said, "no problem, our techs will take care of that"
Well we bought it and upon start up to take it home, message appeared! Told sales manager that I remember telling you this message was on DIC etc,etc.

Took it in this am and they had it all day "we have to order a module". Now I have a new scratch and dent on the left rear bumper. Called Svc. Mgr out for a look......"we'll take care of it whe we have it back for the module."

Just where is this or are these modules located? By looking at the diagram posted above, it appears they are located just ahead of the rear bumper, about where my new scratch and dent are.......

Thanks,

WR
 

·
Registered
Joined
·
92 Posts
I just replaced my passenger side module. Problem started with an intermittent "Service Side Detection System" message that appeared to be related to wet weather. I initially suspected a wiring issue. Took off the rear bumper and after probing around decided to remove the sensor. It was very hard to remove because it was swollen! The pocket that it was mounted in was full of water and mud and moisture made its way into the sensor. Driver's side sensor was clean so I suspect the passenger side was inundated with water during the floods we had last fall.

Anyways, ordered a new harness (destroyed the old one probing it for shorts) and a sensor. New harness appears better built and has less slack. Sensor is now made in Canada instead of USA but appears to be same design. I added additional silicon to the sensors and the pockets they sit in in the hopes of avoiding the same problem.
 

·
Registered
Joined
·
5 Posts
Just got a call that my new module is in and have scheduled it to be taken in Wednesday. Since we initially purchased this vehicle, there have been more issues arise. The "Parking Assist Off" message began appearing on the DIC every start up and my programmed Homelink stopped working about 2 weeks ago. Both about the same time. I don't listen to XM radio, but my brother does, and when he was checking my Denali out, couldn't get the XM to work.

I went in to talk to the Svc Mgr and the Gen Mgr were standing together, I told them about these problems and what I have learned on this forum. I also said that the GM Engineers have had 3 years to rectify these situations and they should be providing guidance and instruction to get these issues fixed. Unless the modules have had updates or been re-engineered, these issues will crop up again.
 

·
Super Moderator
Joined
·
18,323 Posts
Wrangler Rich said:
... Unless the modules have had updates or been re-engineered, these issues will crop up again.
And, we'd be hearing about it throughout the auto industry - much like the Takata airbag debacle. It's not a thing used (or built) solely by GM.
 

·
Registered
Joined
·
1 Posts
I have getting the "Service Side detection system" in the information center, and can no longer turn it on or off in the menu settings. There is a previous thread that shows where the sensor/modules are located. Anybody have any DYI advice for fixing or turning it off? The lights in the mirror stay on all of the time. Or does someone know what might be involved having it fixed. The above previous post says the modules are $600.
2013 Acadia Denali 62,000 miles.

Thanks in advance.
 
1 - 20 of 157 Posts
About this Discussion
156 Replies
55 Participants
MAD MARK
GMC Acadia Forum
Join our Acadia Forum community where enthusiasts discuss mods and troubleshooting for the GMC Acadia and Denali Crossover SUV.
Full Forum Listing
Top