GMC Acadia Forum banner

21 - 40 of 57 Posts

·
Registered
Joined
·
287 Posts
teetertotter said:
I buy Mobil 1 filter and have local Quick change use instead. We know too that GM filters are okay for replacement. After market filters are not always the same for all engines. Be careful........................
Who would have thought that one would need to be careful re the choice of filter!

So you are obviously confident that the M1-113 filter is just fine for these engines?
 

·
Registered
Joined
·
2,064 Posts
copperbeech said:
Who would have thought that one would need to be careful re the choice of filter!

So you are obviously confident that the M1-113 filter is just fine for these engines?
That is correct.......M1-113 has proper internal construction....bypass technology.....for horizontal mounting application. I read up on Mobil 1 filters some time ago on the internet. Spend the $10.00.....it is worth it to make long story short. Blue is probably all ready doing his research....... :thumb:

Added: Or stay with OEM Delco filter. You will be certain is designed for this engine.
 

·
Registered
Joined
·
287 Posts
teetertotter said:
I read up on Mobil 1 filters some time ago on the internet. Spend the $10.00.....it is worth it to make long story short.

Added: Or stay with OEM Delco filter. You will be certain is designed for this engine.
I have got 3 M1-113s in my basement. They cant be bought in Canada so I had someone buy them while down there and bring them back.
 

·
Registered
Joined
·
20 Posts
I actually had my EaO47 filter fail....

For whatever reason the anti-drainback valve failed in that it came apart! I sent the filter to Amsoil along with an oil sample.... Amsoil tech reported that he could not account for all the pieces of the drainback valve and that it would be a warranty issue should the motor have an issue. The oil analysis came back normal.

Using the WIX filter and have not had an issue as of yet.....

:facepalm:
 

·
Registered
Joined
·
1,323 Posts
HRDROKN said:
I actually had my EaO47 filter fail....

For whatever reason the anti-drainback valve failed in that it came apart! I sent the filter to Amsoil along with an oil sample.... Amsoil tech reported that he could not account for all the pieces of the drainback valve and that it would be a warranty issue should the motor have an issue. The oil analysis came back normal.

Using the WIX filter and have not had an issue as of yet.....
That's not good. At least the ADBV isn't metal and shouldn't cause too many problems....how long ago was this?
 

·
Registered
Joined
·
20 Posts
MedicRxDoc said:
That's not good. At least the ADBV isn't metal and shouldn't cause too many problems....how long ago was this?
It has been almost six months since and all appears to be fine at this point. I will be doing a filter change soon and will have the filter analyzed for any of the undiscovered pieces of the ADBV.
 

·
Registered
Joined
·
1,290 Posts
HRDROKN said:
For whatever reason the anti-drainback valve failed in that it came apart! I sent the filter to Amsoil along with an oil sample.... Amsoil tech reported that he could not account for all the pieces of the drainback valve and that it would be a warranty issue[/color] should the motor have an issue. T
Sounds like a load of C&@P to me!
No accountability for their screw up!! :sosad:

If you have documentation, I would definitely file a suit against them if you have issues down the road - due to this.
 

·
Registered
Joined
·
65 Posts
I have been using the EaO47 in my 2008 GMC Z71 PU for over 40,000 miles (not all on same filter) since new and the filter has not had any problems. Everything was intact when the filters were removed, no problems. I installed one last Nov and traded the truck in with over 10,000 miles on the filter 2 weeks ago.

Its the unique design of this particular engine and these engines ONLY. The EAO47 function perfectly on V8 engines used in big trucks and SUV. Also, a friend use one on his 2009 Suburban for the last year and when he removed it, nothing was wrong with the filter.


Btw - I seen a mention of the 3.6L CTS engine but that engine uses a different style filter, its a cartridge type and not a spin on like the Eao47. I know I have such a car.
 

·
Registered
Joined
·
500 Posts
Discussion Starter #29
HRDROKN said:
I actually had my EaO47 filter fail....

For whatever reason the anti-drainback valve failed in that it came apart! I sent the filter to Amsoil along with an oil sample.... Amsoil tech reported that he could not account for all the pieces of the drainback valve and that it would be a warranty issue should the motor have an issue. The oil analysis came back normal.

Using the WIX filter and have not had an issue as of yet.....

:facepalm:
How did you find out that the ADV failed? What was the indications? How long ago was this because the message not to use them has been out a while now. Your AMSOIL dealer should have informed you to remove them once the message came out that they were to be discontinued for use.
 

·
Premium Member
Joined
·
15,751 Posts
hammerb29 said:
Just wanted to let everyone know that AMSOIL has replaced the EA047 filter with a new EA050 for the Acadia.
Thanks for the update
 

·
Registered
Joined
·
20 Posts
Rat407 said:
How did you find out that the ADV failed? What was the indications? How long ago was this because the message not to use them has been out a while now. Your AMSOIL dealer should have informed you to remove them once the message came out that they were to be discontinued for use.
No indications at all... I was due for an oil change and discovered the problem. When I did the research I found that Amsoil was already aware of the issue? :shrug:

BTW... sorry for the late reply.

:cheers:
 

·
Registered
Joined
·
500 Posts
Discussion Starter #36
HRDROKN said:
No indications at all... I was due for an oil change and discovered the problem. When I did the research I found that Amsoil was already aware of the issue? :shrug:

BTW... sorry for the late reply.

:cheers:
No problem. Did you get the filter from AMSOIL's web site or a local dealer? You should have gotten a message stating that the filter was to no longer be used and to discontinue use if you had one installed. I wonder where the ball got dropped?
 

·
Registered
Joined
·
20 Posts
Rat407 said:
No problem. Did you get the filter from AMSOIL's web site or a local dealer? You should have gotten a message stating that the filter was to no longer be used and to discontinue use if you had one installed. I wonder where the ball got dropped?
Well.... I get my oil through my dad, so kinda hard to make an issue. He probably got the notice, read it, filed it and never thought who might be using the filter.

:shrug:
 

·
Registered
Joined
·
237 Posts
I just bought a Fram Extra Guard (PH10060) oil filter. On the box, there's a chart that says the 'Extra Guard' does not have the bypass valve but the 'Tough Guard' does. Should I return it and get the ACDelco PF48 or the Mobil 1 M1-113? Or is this oil filter ok?
 

·
Registered
Joined
·
8,458 Posts
I would go get the PF-48.
That way theres no issues if theres some kind of problem.
Someone here or the traverse forum had some issue- and they spotted a white filter- and I think they mentioned possibly not covering the problem because of the filter that was used....
anyone know the outcome of that owners problem>?
 

·
Registered
Joined
·
136 Posts
21 - 40 of 57 Posts
About this Discussion
56 Replies
22 Participants
Rat407
GMC Acadia Forum
Join our Acadia Forum community where enthusiasts discuss mods and troubleshooting for the GMC Acadia and Denali Crossover SUV.
Full Forum Listing
Top