GMC Acadia Forum banner

Are you experiencing this problem?

  • Yes

    Votes: 0 0.0%
  • No

    Votes: 0 0.0%
  • N/A

    Votes: 0 0.0%
1 - 10 of 10 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
I’ve had my fully loaded Acadia for nearly 3 months now. I’ve never had a problem with the Navigation until 3 days ago. When I turned on the car I got a message that said something to the affect of “Disk Check in Progress” and an “eject” button in the bottom left corner that was disabled. This message stayed on the screen for the entire drive ~1 hour. When I arrived at my destination I turned the car off and back on. The navigation worked flawlessly.

I remember reading on this forum a post of someone who had a similar issue. The recommendation was to eject the disk and check for scratches. So I ejected my disk; it was in perfect condition. I loaded it back in, and everything was still ok.

Then yesterday while I was driving the Navigation rebooted, it brought up the GMC logo screen and then the “Disk Check in Progress” again. 20-30 second later the program loaded and the navigation was back up.

Is anyone else having this as a reoccurring problem? I’m wondering why it took 3 months for this to start happening.
 

·
Registered
Joined
·
322 Posts
Added poll...
 

·
Registered
Joined
·
524 Posts
It has happened to me about four times. I'm not sure but I think it has something to do with the ignition and accessory/start. I notice that it happens when I am in the car with the ignition turned on but car not running. Then if the system times out and I re energize a couple times it may go into disk check mode, then the warning info comes on the screen and I have to push the OK button, then all is well. An annoyance, but not a huge issue. Perhaps one of the insiders could elaborate on this.
 

·
Premium Member
Joined
·
14,870 Posts
This thread is from 07; those previous 3 members are ghosts. Maybe someone else can chime in
 

·
Registered
Joined
·
88 Posts
I was getting "Read Disk Error" intermittently. Brought it in to the dealer, expecting them to tell me they could not reproduce problem. Amazingly, they said the radio needed to be replaced. They need to order the radio, so, they told me to call them 2 days before I bring the car back.
 

·
Registered
Joined
·
57 Posts
Perfect

Google does not say much.

I'm done! I've found an armada, I'm out. Done with this pos and all it's electrical, tans and roof leaks.

I will lose my mind if my wave plate takes a dump on the way to the dealership.
 

·
Super Moderator
Joined
·
22,026 Posts

·
Premium Member
Joined
·
14,870 Posts
Just like anything mechanical; sometimes you get one that just doesn't want to play nice. Good luck CJATE; hope the Armada gives you trouble free miles
 

·
Premium Member
Joined
·
2,618 Posts
Kingsfr said:
I was getting "Read Disk Error" intermittently. Brought it in to the dealer, expecting them to tell me they could not reproduce problem. Amazingly, they said the radio needed to be replaced. They need to order the radio, so, they told me to call them 2 days before I bring the car back.
Kingsfr,

I’m sorry you were experiencing this issue, but am happy to hear your dealer is taking care of you!

If you have any questions or concerns in the future, please feel free to contact me.

Please keep us posted.

Louis (assisting Michelle)
GMC Customer Service
 
1 - 10 of 10 Posts
Top