GMC Acadia Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Wife and kids were on their way home, got about 3miles from home. She says she lost power steering and noticed the gas wasnt working either coasted to a sidestreet and waited for me to get there. Had it towed home and i cant get it to start, it will crank over and want to start. Im thinking its a fuel issue but where to start is the question. Ive been searching and reading for the last 2 days.

I threw my scanner on it and there are no codes So where do I start? Ive downloaded the factory service manual so i have it handy. I cant hear the pump running when i turn the key on.

Prior to this happening, if it sat a couple couple days with out going anywhere it took longer to start.

Im thinking its either the tank pump or the high pressure pump. Is there any situation where either one of these fail but wont register and code?

Thanks in advance.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
If you are not hearing the fuel pump, I would start with the fuel pump relay and fuse. If those are good than it is most likely the fuel pump has failed....................or your out of gas. :)

I could not find a fues or relay in the box under the hood or glove box. Is it labeled as something other than fuel pump?


Definitely not out of gas has about 1/2 tank in ATM.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
I think the fuse is labelled FPCM for fuel pump control module.
I found it just fuse was fine but replaced with another just to try and still didn't work.

Going to start dropping the tank and replace the fuel pump.

May go to the junk yard and get a fuel control module just to help trouble shoot.

If the high pressure pump went bad but the low pressure was good wouldnt it still spit and sputter? Or would it not run like it is now?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
Update*

I went to the junk yard on Sunday and grabbed a FSCM and a high pressure pump. I did not get the fuel pump in tank, I will order new if needed.

I swapped out the Control Modual and tried to start it. No luck.... still no code. I will check that plug under the driver seat area, but also plan on doing the high pressure pump at this point.

Is there a write up on chaging that pump. I recall the cam lobe needs to be in a certain position.

Thanks for all the help so far.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #11 ·
Well, last night I changed the high pressure fuel pump. Thanks for the video it saved a bunch of time. Unfortunately it did not help. I also checked the plug under the drivers seat, it wasn't loose at all. I did unplug and replug and still no luck. Im gonna start dropping the tank tonight and hopefully a new pump will be the key. Im still not seeing any codes or CEL coming on.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #14 ·
You dont say, but since you put in a used hpfp, you may have reused all the parts.
GM says not to reuse some of those parts as they could leak gas in the engine compartment. When new, the connecting ends deform to make a proper seal.
I only got the hpfp and fscm used as tools to help trouble shoot. I figured since I would have to drop the gas tank for the fuel pump it was going to be a new part. Which is what i did. That did not work, so i had it taken to a shop begining of this past week.

I have talked to the mechanic and he hasn't been able to figure it out as of late friday.
No codes on his scanners, fuel pressure is great. Compression is good. He said its got him scratching his head too. Hes going to check timing on monday.

I did the timing chain and phasers 2 years ago and my wife has only put about 15,000 miles at most in that time. (not ruling out a timing issue) The car has ran great with no other issues so at this point i'll wait and see what the shop come up with. I will continue to update in hopes that the info may help someone else.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #15 ·
Got an update from the shop today, the culprit is the ECM. Found several in the area but the shop isn't capable of programming. Any suggestions on best route to take. Im not familiar with the program side of these .
 
1 - 7 of 7 Posts
Top