GMC Acadia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I own a 2009 Acadia and have been having some electrical issues for about a year. The most noticeable is that the radio is super quiet. Sound only comes out of the speakers on the pillars, no other speakers put out any sound (we don't have the Bose amplifier). Other indications are that the airbag light came on and won't go out and nothing works on the passenger side as far as power windows and locks. Everything else seems to work fine including all lights and the gauge cluster.

So far I have checked all of the fuses, emptied out the door connections (there was a small amount of water in them) and disconnected and reconnected the BCM. No luck with any of the problems listed above. Any advice is appreciated.
 

·
Registered
Joined
·
2,431 Posts
When you emptied the water out of the door connections, did you make sure all the pins were still intact?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
When you emptied the water out of the door connections, did you make sure all the pins were still intact?
Yep, the pins and connections all looked good. There weren't even signs of rust or corrosion. Most of the water came from where the harness bends back up. I cut some small drain holes at the bottom of the "drip loop" just so it doesn't happen again.

I did all of that about awhile ago and then we moved to Arizona. We don't get a whole lot of rain down here...
 

·
Super Moderator
Joined
·
19,789 Posts
It's been an uncommon occurrence for all door speakers to fail at once, but it has happened. You should be able to check speaker output at each speaker connector to see if that's the case.
 
1 - 4 of 4 Posts
Top