GMC Acadia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited by Moderator)
Need help!
I have a 2012 GMC Acadia Denali with 143k miles. I'm having a ton of issues that may or may not be related to each other. I don't have the means to replace non broken random parts hoping that's the issues; and I don't want to waste my time either lol.

Issues:
1. Feeling in gas petal similar to if you're riding the white line except smoother. Kind of like a slight grip. No sounds heard, but the feeling has a sound to me (like a deaf person listening to music I guess). I personally feel like I can feel it coming from the front passenger wheel area. Started approximately 2 months ago. Hasn't gotten worse over time that I've noticed but still concerning.

2. A/C vents in front won't switch from dash to vents or floor. Started happening multiple repairs at once occured.

3. A/C button with snowflake blinks and shuts off after pressed. Heat still works perfectly

4. Electrical issue of some kind while driving. Speedometer, rpm meter, gas gauge, temperature, battery voltage, holographic speed displace, driver window control button, automatic locks, radio, dvd player, programmed seat button, automatic lights, cruise control, blinker notification, and all other driver electrical items stop working. The dash shuts down randomly while, but the lighting to it changes to daylight brightest if headlights are on. Sometimes only some of the other things go out and sometimes all of them do. When the passenger door is opened they turn back on for a second and back off. The car information display reads, check air bags, check tires, check gauges, and all my service lights turn on. This happens on and off, duration time different each time. Sometimes its quick, sometimes it doesn't fix itself and I finish my drive like that. When driver window control won't work the back windows will still roll down if back buttons are utilized, even if my window locks are on. The rain doesn't make it happen more often, but I am in Florida with high humility? This happens while driving and does not cause any change in speeds. Started with just the tire flat light randomly and grew to this over the last 2 months or so.

5. Doesn't turn over sometimes. Turning the key turns on the power, but no noises when trying to start. If I repeatedly turn the key until it starts. I have found I must hear a clicking sound it will start when the issue occurs. If I don't hear the sound the car acts as if the power drained completely, but power works in on mode with no issues when clicking noise is found. I push my key harder, in different angles, and/or remove and insert key repeatedly to get noise.

6. Car temperature rises in park or idle sometimes. Most the time turning the heat on lowers temperature, sometimes it doesn't. Sometimes no temperature issues occur.

Last I checked no codes show up aside from front passenger communication loss but window and lock have been broken since I bought it 6 months ago. And it reads low voltage to the 4th and 5th transmission circuit. I do have a slight jump going into fourth gear, but nothing major.

On a single occasion my husband and his mechanic cousin repairs multiple things at one time, after the repairs is when the vent stopped switching out of defrost blowing only.

The repairs they did: all motor mounts replaced, all breaks replaced, all rotors replaced.

They disconnected the battery during the repairs for something I'm unsure of and I do believe they said the fuse box or relay box to get to mounts.

All I know is I don't wanna speeding ticket, to run out of gas, not have music, and/or loose complete power while driving. I literally just paid cash out 17k for this in August and never even had that much money before in my life, let alone spent it on a car before or maybe ever can again so I have to fix this because it has to last. I've got six little ones, so I can't afford to put it in a shop..

The problems might all be unrelated or combined to one solution, who knows. But has anyone had any of these issues? Especially issues with the power loss and starting?

Tires are brand new all around. Oil change up to date. Very rarely drove low on gas and almost always filled each time. Transmission fluid good. Power steering no issues. No issues with major steering pull. No issues with breaking or accelerating. No irregular sounds. Rare idle irregularities.

Personally think it doesn't seem like:
Starter - more like it needs to register not like its struggling to work.

Alternator - voltage steady and doesn't power down.

ECM - everything else works, turns over, doesn't shut off.

Helppp!!
 

·
Registered
Joined
·
180 Posts
You certainly seem to have a number of problems.

Firstly, you got swindled for paying $17K for a 2012 Acadia Denali with that many miles; and secondly, it would make me question what other issues they thought they could stick you with.

Honestly, with that many problems, you need to see a qualified and trustworthy mechanic or take the vehicle to a GMC/GM dealer.
 

·
Registered
Joined
·
2,942 Posts
I agree with @SpartyOn, you way overpaid for your Acadia. Seems you have bought a truckload of someone else's issues.

I would be most concerned about the overheating and it would be the first issue I would diagnose. That diagnosis would determine how much money and time to sink into additional repairs.
 
1 - 3 of 3 Posts
Top