GMC Acadia Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My wife’s 2013 Acadia had been hard starting for about 8 months , “finally a light come on lost communication to fule pump “. Replaced high pressure, and tank pump . New purge valve sil , new plugs . Then 3 months ago it started going dead all the sudden, and jerks or bucks while under a load . My wife has herd they have awful trans problems. But It shifts to smooth and to many air fuel problems going on for me to jump off the “bad trans “ cliff.
02 sensor is next also mass airflow has been changed out .
Any suggestions please
 

· Registered
Joined
·
3,487 Posts
Get a high quality capable ODB scanner to check for actual failure codes to properly diagnose.
Or . .. take it into a reputable shop with proven history of finding issues like yours.

Throwing parts at a problem can run up $$$$ and not solve the problems.
 

· Registered
Joined
·
65 Posts
My wife’s 2013 Acadia had been hard starting for about 8 months , “finally a light come on lost communication to fule pump “. Replaced high pressure, and tank pump . New purge valve sil , new plugs . Then 3 months ago it started going dead all the sudden, and jerks or bucks while under a load . My wife has herd they have awful trans problems. But It shifts to smooth and to many air fuel problems going on for me to jump off the “bad trans “ cliff.
02 sensor is next also mass airflow has been changed out .
Any suggestions please
Yes, mechanical problems don't fix themselves, and when a vehicle starts having problems, get it fixed now, not 8 months later. You can only do more damage. Women don't know any better. You should.
 

· Registered
Joined
·
20 Posts
My wife’s 2013 Acadia had been hard starting for about 8 months , “finally a light come on lost communication to fule pump “. Replaced high pressure, and tank pump . New purge valve sil , new plugs . Then 3 months ago it started going dead all the sudden, and jerks or bucks while under a load . My wife has herd they have awful trans problems. But It shifts to smooth and to many air fuel problems going on for me to jump off the “bad trans “ cliff.
02 sensor is next also mass airflow has been changed out .
Any suggestions please
it could be any number of things at this point.

does it bog down if you just rev it in Park? Or it idles normal and only bogs down when you try to accelerate?
 
1 - 5 of 5 Posts
Top