GMC Acadia Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
All -

I am about to install a AVIC-D3 with XM and BT into my wife's 2007 GMC Acadia (which has the GMLAN interface). I could have sworn that I read something somewhere that alluded to the fact that some of the early interfaces had some sort of "bugs" that were worked out later. I bought the first interface which supposedly works, a Peripheral GMAHLANB (her Acadia has the Bose system), but a local shop that does installs for the GMC dealership mentioned they were questionable and they'd prefer to use the PAC OS3-BOSE interface. They couldn't seem to state any specfic "bugs", and frankly these look like IDENTICAL units with different stickers on them. Can anyone confirm the GMAHLANB (which I will pair with a PESWIPS for steering controls) works fine with this or a very similar 07-08 GMC? Thanks!!

Mark
 

·
Registered
Joined
·
405 Posts
gasuntite, i think my mind sparked out after reading that. :confused: :confused: :confused: :confused: :confused: :confused: :confused: :confused: :confused: :help: :help: :help:
 

·
Registered
Joined
·
122 Posts
Installing the D3 is something I have been looking at also. Are you doing the install yourself? If so, Can you take some pics while you are installing? and then also some pics of it completed. I'm interested to see how "factory" it looks.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
Sorry, BG, I didn't do it myself so no pics. I did get it done with the GMAHLANB and PESWIPS and so far so good. I haven't tested Onstar yet, and the phone button on the steering wheel doesn't trigger the BT addon for the D3, but the volume and FWD, BACK work, and I think this setup is 10X better than the GMC unit, which was in our first Acadia.
 

·
Registered
Joined
·
730 Posts
Great!
Could you share some pics? Just wanted to see how well did it fit. I'm interested in getting one myself.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #6 ·
I'll try to get some up in the next day or two. FWIW, it looks great, but it is a glossy black bezel on the D3 instead of matte black like the rest of the instrument facing and the Metra kit. Looks great nonetheless. I will say avoid the Bluetooth module if you were thinking about it, unless you have a Moto Q, RAZR, or Blackberry, because it hasn't worked on my wife's Moto, or my Nokia or my T-mobile MDA (same as Cingular 8125).
 

·
Registered
Joined
·
405 Posts
i read in "our first acadia "and i am getting curious, do you have two or did somthing go wrong that they couldnt fix and they gave you annew one.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #8 ·
Rollin' Thunder said:
i read in "our first acadia "and i am getting curious, do you have two or did somthing go wrong that they couldnt fix and they gave you annew one.
That is an odd statement, huh? Actually, we did have one of the very first Acadias to be had. We picked it up on January 3rd. It actually had several "small" problems that gave us no long term concern at all, but which collectively needed to be fixed to prevent serious frustration and inconvenience on our part. On item in particular, was that one of the 2nd row captain's chairs broke and would not stay upright, which is a problem when you tote 3-5 kids and 2 adults almost everywhere you go (my in-laws live half a mile from us) and your wife is 7 months pregnant, making it difficult at best to overcome the issues that created. Long and short of it is the parts weren't in the system yet, and when they started trickling in the first ones were already broken or getting "stolen" out of the parts order during the distribution process. Ultimately, GMC made it right and bought the car back, and the following week we ordered what would become one of the last of the 2007's, with a build date in June. We love the new one (as we did the old - even with the initial problems), and we've had ZERO problems with this one.
 

·
Registered
Joined
·
3 Posts
I think I know what some of the bugs are with the early wiring harness'. I had a Kenwood DNX-7100 Nav installed in my car. The biggest issue is that when you use OnStar the entire head unit shuts off. When the OnStar cuts off everything comes back on. The other issue is the chime for the turn signals. It is a knocking sound that after a few seconds gets to be pretty annoying. I've heard that these issues have been resolved with some of the later harness' but have not had a chance to test it.

I would be curious to see some pictures of systems that others have installed. I am actually considering changing to the Pioneer AVIC-Z2.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #11 ·
All -

I am really sorry it took so long, but been busy (had another kid, etc.). For those of you who wanted pics of it installed - here you go:







The only problem I've noted is that under very rare circumstances where I'm on retained accessory power and I turn off the unit and then turn it on before getting out (or something like that) and the power stays on. Anyway, really rare (so I haven't noted the exact issue), and it hasn't bitten me yet. My only complaints - the BT unit for the AVIC stinks (get a Parrot instead), and the steering wheel forward/back go up and down 1 channel in XM, not 1 preset. Otherwise, works great, and is VASTLY superior to the GM solution.
 
1 - 11 of 11 Posts
Top