GMC Acadia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I have an 08 Acadia SLT1 with 95,000 miles. I bought it in November 2013 with 83,000 miles. I was in the drive thru tonight getting my kids dinner before dropping them off at my cousins for the weekend. When I went to pull out, my car made a weird jerk. I thought my tire was against the curb so I turned the wheel and pressed the gas pedal. It didn't seem like it really wanted to accelerate. The car seemed like it was revving more than it was accelerating. I noticed right away that the check engine light came on. So I pulled into the parking lot and shut the car off. Waited about 30 seconds or so and started it up again. I sat there a couple minutes in park and it almost felt like it was chugging a little at idle. Gave it a few revs and it sounded clean. Put it in drive and drive away and it was driving like normal but the check engine light was still on. So I dropped the kids off and wait straight to Autozone (about 10 miles total) and the ran a scan on it. It pulled these 3 codes that were thrown 7 times between the 3 of them tonight... P0700, P0716 and C0899

I've had the car about a year and 2 months. The only problems I've had are that I had the power steering pump, gear and the rack and pinion replaced last May. I've had the oil changed regularly and it has never thrown codes before. Any ideas on what's going on??? I do plan on taking it to the dealer tomorrow... ???
 

·
Super Moderator
Joined
·
18,300 Posts
You could be looking at something like a PCM problem, or the precursor to a 3-5-R wave plate failure. Good luck.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
So I took it to a GMC dealer this morning and he ran the codes and one of them said to test the battery first. So the battery was only putting out half the voltage it should be. It is also the original battery so 7 years old and 99k miles on that battery. This morning when I left my house, the check engine light was off. So the tech suggested I get a new battery and see what happens. He said a low voltage battery could cause communication problems triggering other things to think there's a problem. We will see...
 

·
Super Moderator
Joined
·
18,300 Posts
Im having the same problem any help please
Welcome to the forum. Many threads contain discussion of this problem. It's suggested to use "p0716" in the forum search box and read those threads.
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
3 Participants
speleos
GMC Acadia Forum
Join our Acadia Forum community where enthusiasts discuss mods and troubleshooting for the GMC Acadia and Denali Crossover SUV.
Full Forum Listing
Top