GMC Acadia Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited by Moderator)
Hello all,

I'm looking for any help I can get on this. I recently had to replace the motor in my wife's 2011 Acadia and it was a long drawn out process as myself and my friend who helped are by no means "professionals" so I'm hoping this is something stupid that was done. The motor was a new crate long block that came with new vvt selenoids and all I had to do was swap timing cover/oil pan/fuel rails and injectors and everything above the intake plenum.

This went off without a hitch for the most part and I had the car running for well over a combined time of 60 minutes while I checked everything over and worked to bleeed the air out of the cooling system. While all of this was going on the car was stationary and was started and stopped many times and I had no errors.

HOWEVER once I took it on a test drive I got the following errors:

P0013
P0023
P2088
P0010
P0020
P0031
P0030
P0051
P0050
P0458


If I reset the codes and start the car they don't come on but as soon as I shut it off once and turn it back on they come back.
I'm no mechanic but it smells like the car might be running a little rich as well. I had access to a scan tool and tried to read (Assuming I was doing it right) the values for all of the actuators and all the values are 0 I don't know if that is part of the problem or if I did something wrong in the test.

Can anybody help me figure out what is going on? I have attached pictures of the codes and the test data if it helps. Font Computer hardware Gadget Gas Technology
Light Gadget Communication Device Gear shift Font
Gadget Font Audio equipment Material property Display device
Computer Light Gadget Font Audio equipment
Font Material property Display device Automotive lighting Wood
Computer Gadget Font Personal computer Display device
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
Turns out if bank 1 intake VVT solenoid fails it can cause all of these errors. I ended up ohming out each vvt and all were around 7 ohms except the first one which was nothing. I replaced that and all errors went away.
 
1 - 2 of 2 Posts
Top