GMC Acadia Forum banner

21 - 30 of 30 Posts

·
Premium Member
Joined
·
14,870 Posts
dfalgout said:
My transmission broke 25 miles before the warrant went out. Turns out this is a regular issue the dealer will not recall. Beware before buying. There is this plate inside the tranny well it broke. I lost my reverse and when it shifted there would be a loud noise and a hard jering sound.
This is a well documented issue on this forum
 

·
Registered
Joined
·
2 Posts
2013 Acadia Denali

I have replaced my cats all three and the 4 O2 sensors TWICE and i keep getting codes for P0420 & P0430 cats bank one and two performing under threshold value.. anyone have any ideas on this.. I cant believe that two seprate sets failed, and two separate sets of O2 sensors failed. All within 500-1000 miles of installation.
 

·
Registered
Joined
·
2 Posts
2013 Acadia Denali Cats

recently I had to do a Head job on my 13 Acadia Denali after it broke a valve at 85K. After this head swap I have been having issues with codes P0420 & P0430. I have replaced my cats all three and the 4 O2 sensors TWICE and i keep getting codes for P0420 & P0430 cats bank one and two performing under threshold value.. anyone have any ideas on this.. I cant believe that two seprate sets failed, and two separate sets of O2 sensors failed. All within 500-1000 miles of installation. does anyone have any ideas what may be goning on. the vehicle runs great with the exception of a decrease in fuel economy from prior to head job, but nothing earth shattering, and like i said it really does run well. Thank s
 

·
Registered
Joined
·
22 Posts
I am having issues with Bank 2, I was told it was the cat had needed to be replaced and it was the one in the front. I called around to get some quotes and one place told me it was the firewall side. Can someone clarify this? I have an 09 gmc acadia v6
 

·
Super Moderator
Joined
·
20,893 Posts
I am having issues with Bank 2, I was told it was the cat had needed to be replaced and it was the one in the front. I called around to get some quotes and one place told me it was the firewall side. Can someone clarify this? I have an 09 gmc acadia v6
Bank 2 is the radiator (front of the car) side of the engine.
 

·
Super Moderator
Joined
·
20,893 Posts
... Is this something that is simple enough to replace?
It's not too bad of a DIY job. Simple is something you'll have to determine for yourself.
 

·
Registered
Joined
·
22 Posts
Alright well on the bright side - we were able to replace Bank 2 Catayltic Converterr but still having issues with the car sputtering. Changed all six spark plugs and one of the ignition coils. Driving into work this morning the check engine light came on. This time the code P0420 or bank 1. We're supposed to be going on a trip this weekend and I have family willing to help with the cost of purchasing a new converter and replacing the one on Bank 1. What would cause this? There has never been a problem with that side, this is the first time a code has flashed for Bank 1. When I took it to the shop last week they said my bank 2 was bad but nothing about bank 1.
 

·
Super Moderator
Joined
·
20,893 Posts
It could be something happening upstream from the catalytic converter, i.e. leaky (dirty) fuel injector, poorly performing engine coolant temperature (ECT) sensor, engine timing problem. Put a bottle fuel injector cleaner in the next tank of fuel - a good first step. If the running problem persists, find someone with intimate knowledge of fuel injection diagnosis.
 

·
Registered
Joined
·
1 Posts
2013 Acadia Denali Cats

recently I had to do a Head job on my 13 Acadia Denali after it broke a valve at 85K. After this head swap I have been having issues with codes P0420 & P0430. I have replaced my cats all three and the 4 O2 sensors TWICE and i keep getting codes for P0420 & P0430 cats bank one and two performing under threshold value.. anyone have any ideas on this.. I cant believe that two seprate sets failed, and two separate sets of O2 sensors failed. All within 500-1000 miles of installation. does anyone have any ideas what may be goning on. the vehicle runs great with the exception of a decrease in fuel economy from prior to head job, but nothing earth shattering, and like i said it really does run well. Thank s
Hey there,
Did you have any luck fixing this. I am experiencing the same issue, I bought it used from a dealership and 3 months into owning it all 3 cats failed and had to be replaced and they replaced all of the o2 sensors. 2 months later, I am getting similar symptoms that I got before this happened. I'm terrified its going to just keep happening.
 
21 - 30 of 30 Posts
Top