GMC Acadia Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
has anyone had any problems with the engine still running even after you have turned the key to off and removed it? this happened to me about 2 months ago, took it to dealer who said it was the cruise control mechanism. they put a new part in and it stopped. well it just happenned to me again!!! anyone have any similar problems or suggestions on a potential problem?
 

·
Registered
Joined
·
38 Posts
I've never had that happen, but I'm curious... does the rest of the car go into it's "shut down" phase? In other words does the dash turn off, the seat move back, radio turn off (if the door is opened).... or does everything stay on as if the key were still in the ignition.
 

·
Registered
Joined
·
6,695 Posts
I've never had that happen either. Very Strange! What happens if you put the vehicle in drive? Does it go?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
the car does go into "shut down" mode, dash lights off, radio turns off, unable to shift car into gear. I took it to the dealer again and it occurred there so they dont think i am crazy anymore. they could not figure it out but when they called GM one of their techs remember another acadia having that problem. cure was to replace engine compartment fuse box. so they did. took it home worked great for a day and half. went to start it the next day and would not turn over!!!! (Piece of @#[email protected]#$%) all dash lights came on, radio, windows working, but no reaction from starter. couldn't shift the car into gear, so had hard time getting it onto flatbed. towed to dealer. third time it has been in for electrical/computer problems. fourth time lemon law in NY.!!!!

very frustrating to give the dealer a brand new car and get 01' Le Sabre to beat on.
 

·
Registered
Joined
·
730 Posts
jakebuddy20 said:
very frustrating to give the dealer a brand new car and get 01' Le Sabre to beat on.
sorry for hijacking the thread.

ok ok. :banghead:
I have gotten over it and had previously decided not to share what I got when my Acadia was serviced.
But here goes: Buick LeSabre 2005
 

Attachments

·
Registered
Joined
·
133 Posts
Did they ever resolve this??? Our just did it for the first time this weeekend.
 

·
Registered
Joined
·
384 Posts
tdrumm said:
Did they ever resolve this??? Our just did it for the first time this weeekend.
OK, this is a weird thing to have happen. Jakebuddy20, if you are out there let us know how this was resolved, please.
 

·
Registered
Joined
·
2 Posts
It looks like they are still having problems with this issue. My Acadia was in the shop 3 times before they figured out how to fix this issue- after previously changing the ignition , they received a bulletin and corrected the problem - they think... If this was the only problem I've had I'd be happier with my Acadia.
 

·
Registered
Joined
·
2 Posts
my 08 acadia had the same problem, take key out still runs, it was a water leak like all the rest. they fixed water leak and i havnt had a problem since.
 

·
Registered
Joined
·
1 Posts
had this same problem when we were going to leave for vacation and then the cars electrical went haywire. They narrowed the issue down to the ignition needing a 5 volt reference to run all the components. The car running w/ignition off was one of issues. They ended up replacing the ignition module (HUB) he said to me. Been fine ever since....
 

·
Registered
Joined
·
6 Posts
Sigh....I just had this happen to me today! Along with the engine light coming on and a warning that "Engine too hot turned off AC" and the whole car fogged up. They would not let me drive it and had to tow it. I have yet to hear what they say is wrong. BUT that has not been my only issue. It is an 07 with 34K miles...At 30K my stabilizer links went then a week later my alternator went while I was driving down the highway in the middle of a rain storm. NOT FUN!!
What constitutes a lemon law? I am sooo concerned because I am getting close to 36K and then what happens to the warrantee??
Any advice? I am meeting with the dealer tomorrow. I am so deflated. I love my Acadia and just do not want to have to deal with all these issues.
 

·
Premium Member
Joined
·
3,374 Posts
As nice as they are, this is why I'll never build a car with the "electronic" throttle as was used in the Corvette & some of the trucks. I haven't looked into if the Lambda uses this setup, I sure hope not.

I hope you all get this worked out.
 

·
Registered
2007 Acadia SLT AWD 300,000 Miles
Joined
·
7 Posts
this is usually water leak from somewhere onto the fuse block. for me was the windshield.
 
1 - 15 of 15 Posts
Top