GMC Acadia Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Good afternoon, I'm new to this forum and just purchased a 2007 gmc acadia. The SUV seems clean but does have over 190,000 miles. Runs and drives but has issues with transmission. After about 10 minutes driving the transmission seems to slip out of gear and goes nowhere. I've heard about the wave plate but also understand that it would make noise if it broke, I've taken apart the TCM and found 3 of the 4 solenoid switches were bad. I replaced them and put everything together but transmission still seems to slip out. I also have multiple codes that show up with my scanner but was looking to update it with maybe a Bluetooth or maybe foxwell hand held. Has anyone had this kind of issue after replacing the switches and what is the best scanner to use with this vehicle. Thank for accepting me into this forum and please forgive me if I have posted this in the wrong area.
 

·
Super Moderator
Joined
·
20,291 Posts
Welcome to the forum.
Hope you get some good feedback about the scanner you seek. I put your post in the DIY section because it seemed to fit best. You'll find the search tool is handy for finding information others have posted about particular technical subjects. Please post any future technical questions about the vehicle itself in an appropriate part of the forum. Thanks.
 

·
Registered
Joined
·
330 Posts
I've had two transmission go on both my Acadia and Enclave and neither made noise when they went bad. Also, post the codes you are pulling and that will help figure out what is going on.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
what about the bluedriver scanner? is BT and has an IOS APP, so far good on scan this car.
Thanks for the info, I have read good things about this scanner and have already ordered one through Amazon. Hopefully it will get me some better answers then the $20 dollar scanner I have currently. Thanks again.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
I've had two transmission go on both my Acadia and Enclave and neither made noise when they went bad. Also, post the codes you are pulling and that will help figure out what is going on.
Thanks for the input, just to make sure I understand, if the wave plate has broken, would the transmission still shift correctly for the first 10 minutes of driving vehicle? For some reason I thought if it was bad it would have sounded like a bag of marbles in the oil pan. As for the codes, I was able to retrieve some with the current scanner I have. Here they are: p0010, p0020, p0030,p0036,p0053,p0054,p0043,p0327,p1527,p2300,p0134,p0345 and p0700. One question i have is should i clear these codes and run vehicle to see what comes back on and would it take the typical 80 miles of running to see all the codes that it pulls? Any help is greatly appreciated. Thank you
 
1 - 6 of 6 Posts
Top