GMC Acadia Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So I’m having a recurring issue with my 2019 Acadia slt1. As soon as I start the car I can plug my iPhone XR into one of the front USB ports and it will charge.. but as soon as AirPlay starts or I click on projection the infotainment screen will go black and my phone will stop charging and won’t even charge again until car is shut completely off for a while and then turned back on. I have tried different cords, and different phones with no luck... didn’t start happening until recently... any ideas would be helpful!
 

·
Super Moderator
Joined
·
21,780 Posts
Could be a problem with the human-machine interface (HMI) module. The HMI module controls Infotainment functions. A tech will have to check that out with a scan tool.
 
  • Like
Reactions: Remi8384

·
Registered
Joined
·
1,456 Posts
Have you tried it with an android?
How old is the cord? Is it a generic cord or original?
I had issues with my android operating properly, then found a comment somewhere about only using an OEM cord. Bam, fixed.
 
  • Like
Reactions: Remi8384

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Have you tried it with an android?
How old is the cord? Is it a generic cord or original?
I had issues with my android operating properly, then found a comment somewhere about only using an OEM cord. Bam, fixed.
I will try to use oem cord but it always did work with any other cord I tried... have used several cords several times and they all used to work with no avail now... thank you will try!
 

·
Registered
Joined
·
1,456 Posts
I will try to use oem cord but it always did work with any other cord I tried... have used several cords several times and they all used to work with no avail now... thank you will try!
I went out and bought a new Samsung brand cord after reading about it, fixed. Other cords, even brand new.. troubles.
Not saying this will fix your problem, but a few $ is a cheap try.
 
  • Like
Reactions: Remi8384

·
Registered
2017 GMC Acadia Denali AWD
Joined
·
11 Posts
So I’m having a recurring issue with my 2019 Acadia slt1. As soon as I start the car I can plug my iPhone XR into one of the front USB ports and it will charge.. but as soon as AirPlay starts or I click on projection the infotainment screen will go black and my phone will stop charging and won’t even charge again until car is shut completely off for a while and then turned back on. I have tried different cords, and different phones with no luck... didn’t start happening until recently... any ideas would be helpful!
The last iOS Apple update created some automatic security changes.
I would go into the Settings menu and check the Car Play toggles under the “Intellilink” permissions. Could be as simple as the “Allow Car Play With Phone Locked” is toggled off...
Worth a shot.
Also Google your symptoms, many
times you are not the first with such an issue and someone has figured out the fix...
 
1 - 6 of 6 Posts
Top