GMC Acadia Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I have a 2014 Acadia Denali with HIDs. This morning I noticed the RT Hlamp wasn't on when I was behind another vehicle. I assumed the bulb was burnt out. When I got home, I was checking the lamps to see which bulb. I wasn't sure if the High/Low was one or two bulbs. I flashed the high beams and the RT worked. When I went back to low, the RT stayed on for about 10 seconds, then went off. I could trigger the light to come on by manually turning the dial, but the RT lamp would go off after roughly 10-seconds. There also appeared to be a high pitched sound (high, not loud) coming from the lamps, as it would stop when they went off. Although I cannot guarantee they didn't do that before and I was just more in tune while checking them.

So it seems the bulb isn't burn out, but something else causing the issue. Any experience with this.
 

·
Super Moderator
Joined
·
19,661 Posts
Could be the ballast (igniter) is starting to fail. That's what fires the light's arc and keeps it lit. May also be a poor electrical connection somewhere in the lighting system, or even a bulb going bad. The high-pitched sound likely comes from the ballast.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
Speleos, any reputable online source for OEM ballast?

I'm seeing they are roughly $250 on gmpartsdirect.
 

·
Super Moderator
Joined
·
19,661 Posts
Speleos, any reputable online source for OEM ballast?
Don't know of one, personally. Use the part number in a 'net search and see what price you can get from the supplier of your choice. Try the forum vendors, too.
 

·
Super Moderator
Joined
·
19,661 Posts
Wish you well with getting the situation resolved. Let us know if you're successful.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #7
I have ordered a replacement ballast. I'll update the post in a few days.

Sent from my ONEPLUS A5000 using Tapatalk
 

·
Registered
Joined
·
3 Posts
Wish I would have seen this before you ordered. Not sure how much you paid and I am not sure I could have helped, but I just removed my HID lights and went back to Halogen because of the costs of HID. I did remove the ballasts and thought someone might be of use of them. Not sure mine fit yours or not. Mine is a 2011 Acadia. Mine were working fine when I removed them.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #9
I took a chance on a ballast from eBay. I'm sure it's probably used and I don't have very high hopes for it. I'm going to change it out this weekend if it doesn't work I may hit you up.

Sent from my ONEPLUS A5000 using Tapatalk
 

·
Registered
Joined
·
27 Posts
Discussion Starter #10
Well, I changed the ballast today, and it's still flashing. Although the ballast 'looked' new. I still can't guarantee that's not the issue due to the low price I paid.

Is it worth my money to replace the bulb, before I take it to the dealer? If so, what's a good replacement brand? Should I just get an ac Delco from rockauto or a Sylvania?

Sent from my ONEPLUS A5000 using Tapatalk
 

·
Registered
Joined
·
3 Posts
Wow. That is the one thing I didn't save out of my lights or I would have shipped them to you. I was told though by my son that your year and my 2011 is not a match. He says my ballasts won't work on yours, so, not sure if the lights bulb would have worked either.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #12
I just can't believe I didn't think to switch the bulbs while I had the liner out.

I had the non-effective liner half out anyways to put SilverStars in the fog lights. Wish I had switched the bulb to see if that's the issue.

Sent from my ONEPLUS A5000 using Tapatalk
 

·
Registered
Joined
·
1,095 Posts
Have you tried switching bulbs yet to see if that was the issue? If you do , might be a good idea to replace both bulbs if one is going south.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #14
Have you tried switching bulbs yet to see if that was the issue? If you do , might be a good idea to replace both bulbs if one is going south.
That's my plan. Perhaps this weekend I will do that.

can anyone confirm that the OEM bulb is actually just a Philips bulb? I cannot find the exact information but it seems like I read that it's just a rebranded Philips bulb. I don't want to pay $130 for the AC Delco when the Philips bulb is 65.

Sent from my ONEPLUS A5000 using Tapatalk
 

·
Registered
Joined
·
1,095 Posts
I would think if it is a cross referenced replacement that it should be the proper one. Maybe check at a place like a NAPA store. They are usually pretty good at referencing proper parts as they supply parts to many dealers I see the NAPA truck going to and from our local GM dealer all the time.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #16
I would think if it is a cross referenced replacement that it should be the proper one. Maybe check at a place like a NAPA store. They are usually pretty good at referencing proper parts as they supply parts to many dealers I see the NAPA truck going to and from our local GM dealer all the time.
I don't know if it seems Petty or not in a situation where the headlights are different colors.

Sent from my ONEPLUS A5000 using Tapatalk
 

·
Super Moderator
Joined
·
19,661 Posts
can anyone confirm that the OEM bulb is actually just a Philips bulb? I cannot find the exact information but it seems like I read that it's just a rebranded Philips bulb.
The bulb itself might have a maker's mark on it. I know there's one on other factory parts.
 

·
Registered
Joined
·
1,095 Posts
I don't know if it seems Petty or not in a situation where the headlights are different colors.

Sent from my ONEPLUS A5000 using Tapatalk
That's true. . . another reason to buy two bulbs. Even HIDs get less bright as they age, and if both are replaced the color will be uniform.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #19
That's true. . . another reason to buy two bulbs. Even HIDs get less bright as they age, and if both are replaced the color will be uniform.
I have narrowed my search down to the osram CBB or CBI. Both ds3. But I cannot find verification that they work with my vehicle. Do all DS3s work in the Acadia housing?

Sent from my ONEPLUS A5000 using Tapatalk
 

·
Registered
Joined
·
1,095 Posts
Good questions. I have not heard or read any new info on the use of the the different HID bulb classifications for use in the Acadia.
 
1 - 20 of 22 Posts
Top