GMC Acadia Forum banner
1 - 7 of 7 Posts

·
Registered
2012 AWD Denali
Joined
·
29 Posts
Discussion Starter · #1 · (Edited by Moderator)
2012 Acadia Denali w/express up-down, mirrors etc...
Ive been battling my drivers windows for a few months now, and I'm not sure what else to do.
All summer it would randomly get real slow going up and it got progressively worse. More than a few times I would have to revert to starting the engine to get it to roll up at all and then one day it quite working all together. Symptoms all pointed to a bad motor/regulator. Cleaned and inspected the switch for good measure and finally ordered a new regulator but received the wrong one, got the oval two wire instead of the square 3 wire. Got a replacement with the square plug and it worked for about 3 or 4 days then nothing. Warrantied that one back to O'Reileys for a replacement the next day. Swapped it out and it still didn't work. Ive checked for continuity on the 3 wires to the plug and all seems fine, 12v on the red wire, ground on the black and about 6v on the data wire. Ive inspected the harness the best i can and haven't noticed anything broken. Bit the bullet and ordered a new window switch, everything works except for that **** drivers window. Is there anything else that I could try before breaking down and going to the dealer?

Yes I have searched the Forum and the InterWebs, found several topics with the exact issue and same steps taken, but no answers on a resolution. The car needs a new inspection sticker next month so Im running out of time to throw parts at it and money is tight enough as it is.

Motor vehicle Machine gun Bumper Automotive tire Gas
 

·
Registered
Joined
·
3,687 Posts
I had this happen with a rear window on a '11 I once owned. The problem was the glass getting stuck in the frame.

Have you tested it with the door panel off? Does the motor run and attempt to move the window?
 

·
Registered
2012 AWD Denali
Joined
·
29 Posts
Discussion Starter · #3 ·
Have you tested it with the door panel off? Does the motor run and attempt to move the window?
Yes, tested without the panel on and not connected to the window. Cant even run the regulator up to line up the bolt holes for the window.
 

·
Registered
2012 AWD Denali
Joined
·
29 Posts
Discussion Starter · #6 ·
Well it teased me the other day. Took the entire door harness of and ohmed it all out. Positive and ground straight from the door plug, signal wire going the motor to the switch. All wires were good. Put everything back, and it worked for a few cycles. A few minutes later, it didn't work. I think the car hates me.
 
1 - 7 of 7 Posts
Top