GMC Acadia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My 2009 Acadia has started to have a mind of it's own. It has 106K miles on it.
On start up, I get the Stabilitrak and traction control warnings (I've seen these before, but fixed them with new wheel sensors), but now the check engine light stays on, with the U0101 code (only). While driving, the car seems to randomly switch in and out of "proper" operation. Will go 5 or 10 minutes with no issues, but then the door locks switch locked and unlocked, the dash indicator switches from Drive to Park, and back, and the transmission shifting becomes erratic, which includes slippage during shifts, as well as staying in low gear too long.
When not in this problem state, the transmission seems to work as it always has (but I've never liked the feel, too many shifting quirks).
On a 30 minute drive, it will go into this problem state approx 4 or 5 times, for approx 2 minutes each time. The check engine light is on the whole time.
It does not seem consistent with the wave plate and TCM reprogramming issues in this forum, but I would sure like other opinions on that. I plan to clear the U0101 code tonight, and test drive, and then pull the battery cable to reset everything, and test drive again. Thanks for reading.
 

·
Premium Member
Joined
·
15,751 Posts
You're losing communication with the transmission control module. You could be facing a bad or failing TCM; a shorting or open harness or possibly a bad connection somewhere in the GMLAN serial data communication system
 

·
Registered
Joined
·
7 Posts
My 2009 Acadia has started to have a mind of it's own. It has 106K miles on it.
On start up, I get the Stabilitrak and traction control warnings (I've seen these before, but fixed them with new wheel sensors), but now the check engine light stays on, with the U0101 code (only). While driving, the car seems to randomly switch in and out of "proper" operation. Will go 5 or 10 minutes with no issues, but then the door locks switch locked and unlocked, the dash indicator switches from Drive to Park, and back, and the transmission shifting becomes erratic, which includes slippage during shifts, as well as staying in low gear too long.
When not in this problem state, the transmission seems to work as it always has (but I've never liked the feel, too many shifting quirks).
On a 30 minute drive, it will go into this problem state approx 4 or 5 times, for approx 2 minutes each time. The check engine light is on the whole time.
It does not seem consistent with the wave plate and TCM reprogramming issues in this forum, but I would sure like other opinions on that. I plan to clear the U0101 code tonight, and test drive, and then pull the battery cable to reset everything, and test drive again. Thanks for reading.
Hi my 2011 Acadia is having the same issue, could you tell me please what you done to fix the problem?
 
1 - 4 of 4 Posts
Top