TPMS metal or rubber stem - Page 2 - GMC Acadia Forum: AcadiaForum.net
Reply
 
LinkBack Thread Tools
post #11 of 13 (permalink) Old 05-13-2019, 01:51 PM
Super Moderator
 
speleos's Avatar
 
Join Date: Jun 2007
Posts: 17,345
Garage
Quote:
Originally Posted by newz54 View Post
Not the same dealer but I tried him also as I remembered how cheap he was. Not cheap any longer and said his sensors last only 5 years.
Wouldn't install ac delco because he didn't have the right calibration tool. (don't think you need it) i'm going to order the delco units since they have worked well on my tires.
Someone doesn't know what they're talking about. GM's sensors aren't that unique. ACDelco doesn't make the sensors. A sensor I bought from GMPartsDirect was made by Siemens, in France. It came in ACDelco (maybe GM) packaging, though. The original one which came off the car had the same manufacturer's labels. TPMS matching tools are generally setup for activating many brands of sensors. Nearly all TPMS systems operate at the same frequency.

2007 Acadia SLT-2, 'HiYo' Silver outside, Ebony/Titanium inside, no NAV, no HUD, no errors

Last edited by speleos; 05-13-2019 at 02:17 PM.
speleos is offline  
Sponsored Links
Advertisement
 
post #12 of 13 (permalink) Old 05-13-2019, 05:45 PM
Acadia GOD!
 
Join Date: Oct 2009
Posts: 8,384
Issue arose when customers changed the valve caps. Salt helped too.
Dissimilar metals caused galvanic corrosion- and the top of the valve stems broke off.
This became a significant problem that Kent Moore came out with a kit to leave the sensor in place- but you re-cored the sensor.
Interesting how you drilled it down- then made new inner threads- and added a new valve stem.



2010 FWD LT1-Gold Mist Metallic- seats 8.
Build Date- July 31, 2009-2nd day of Spring Hill 2010 production.
2013 Equinox 3.6L - 83,000
2010 Traverse 3.6L- 148,000
2003 Trailblazer 4.2L-181,500
rbarrios is offline  
post #13 of 13 (permalink) Old 05-13-2019, 09:03 PM
Super Moderator
 
speleos's Avatar
 
Join Date: Jun 2007
Posts: 17,345
Garage
Quote:
Originally Posted by rbarrios View Post
Issue arose when customers changed the valve caps. Salt helped too.
They should make a movie - "Aftermarket Mods Gone Wild"

2007 Acadia SLT-2, 'HiYo' Silver outside, Ebony/Titanium inside, no NAV, no HUD, no errors
speleos is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the GMC Acadia Forum: AcadiaForum.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome